AllSecure System - EXCHANGE PLATFORM - Elevated error rate for Creditcard transactions – Incident details

All systems operational

EXCHANGE PLATFORM - Elevated error rate for Creditcard transactions

Resolved
Operational
Started 6 days agoLasted about 3 hours

Affected

EXCHANGE PLATFORM

Operational from 11:38 AM to 3:07 PM

Updates
  • Resolved
    Resolved

    All services have returned to normal operation since the initial notification. The disruption, which temporarily impacted credit card processing for some of our customers, has been resolved.

  • Monitoring
    Monitoring

    The error rate has returned to the normal rate. Our team continues to monitor the health of the service.

  • Investigating
    Investigating

    We have noticed an increase in failed transactions since 12:25 CET, we are currently investigating the cause. We will update you when we have more information.