AllSecure System - Increased number of declined transactions - MasterCard – Incident details

All systems operational

Increased number of declined transactions - MasterCard

Resolved
Operational
Started 7 days agoLasted about 2 hours

Affected

EXCHANGE PLATFORM

Partial outage from 7:25 AM to 8:20 AM, Operational from 8:20 AM to 9:08 AM

Updates
  • Resolved
    UTC
    Resolved

    We can confirm that the issue has been resolved. The service is operating normally, and we have not observed any further impact.

  • Monitoring
    UTC
    Monitoring

    We notice that after 10:15 AM CEST the processing of transactions has gradually stabilized.

    We continue to carry out active monitoring.

  • Identified
    UTC
    Identified

    Our investigation indicates that the issue originates on the Mastercard side and is causing Mastercard 3D Secure authentications to fail. Only Mastercard 3D Secure authentications are affected.

    We will provide further updates as more information becomes available.

  • Investigating
    UTC
    Investigating

    We identified an issue outside of our platform resulting in elevated error rates for Mastercard 3DSecure authentications beginning at 08:50 AM CEST

    Kindly note that the issue at hand is outside our sphere of responsibility and influence. It is a a confirmed 3rd party issue.

    Our incident response teams are actively working to monitor affected services, and we will ensure to provide regular updates on resolution activities.