All systems operational

Banca Intesa Merchants - Elevated rate of unauthenticated 3DS transactions

Resolved
Operational
Started 11 months ago Lasted 4 days

Affected

EXCHANGE PLATFORM
Updates
  • Resolved
    Resolved

    In cooperation with Banca Intesa, we made a certain change in the configuration. It seems to us that this solved the mentioned problem, we see that the transactions are processed smoothly through the 3DS.

    We certainly continue to monitor transactions to make sure everything is working properly.

  • Investigating
    Investigating

    Merchants processing through Banca Intesa appears to have an increased number of failing 3DS transactions.

    Kindly note that the issue at hand is outside our sphere of responsibility and influence. Our incident response teams are actively working to monitor affected services, and we will ensure to provide regular updates on resolution activities.