All systems operational

Mastercard 3DS Partial Outage

Resolved
Operational
Started 11 months ago Lasted about 8 hours

Affected

OPEN PLATFORM
EXCHANGE PLATFORM
Updates
  • Resolved
    Resolved

    Mastercard 3DS transactions continue to be stable. We consider this third party incident resolved.

  • Investigating
    Investigating

    We identified an issue outside of our platform resulting in elevated error rates for Mastercard 3D Secure authentications beginning at 13:05:00 CET

    Kindly note that the issue at hand is outside our sphere of responsibility and influence. It is a a confirmed 3rd party issue.

    Our incident response teams are actively working to monitor affected services, and we will ensure to provide regular updates on resolution activities.