Sat 30.05.2020.

OPEN Gateway Payments Transaction Processing Incident

Resolved AllSecure has restored and validated all domains through the OPEN gateway. All domains have been restored and updated. Transaction processing should now be restored for all customers. If you continue to experience any issues please contact HelpDesk.

Updates AllSecure has updated certificate bundles for most impacted customers. We are validating and working through the full list verifying no other domains are left with an expired CA certificate. AllSecure will report back once all work has been completed and the platform has fully recovered.

Updates AllSecure has restored several additional domains and can confirm transaction processing has been restored. We continue to work through the list of domains as some of them have unique configurations. AllSecure will report back once the incident has been fully declared resolved for all impacted customers.

Updates AllSecure has commenced with updating certificate bundles in several domains. We can confirm some customers have recovered and transaction processing has been restored. Several others remain degraded. AllSecure is working through all domains one at a time testing impact and possible resolution.

Updates The fix has been implemented and rolled back due to negative impact and had unintended side effects. We are analyzing why the fix failed.

Updates AllSecure Incident Response Team is moving forward with a fix updating the certificate bundle after a successful test. The required change will impact multiple domains so we took additional time to validate/test before moving ahead. We could not risk degrading transaction processing even further. The fix is currently in progress.

Updates The incident response team has identified root cause as an expired certificate of an intermediate certificate authority (CA) in the certificate chain. AllSecure is preparing to fix the incident by updating certificate bundles with a replacement certificate of the same CA.

Updates The AllSecure incident response team continuous to investigate the issue. The transaction would fail before it reaches AllSecure so as part of the analysis transaction flows seem to point to an expired certificate. AllSecure server certificates have not expired so we are verifying third party and intermediate certificates currently.

This incident does not seem to impact all customers but transactions processing for the platform is several degraded.

Notification OPEN Payments Gateway is currently experiencing an incident impacting transaction-processing services. Our incident response teams are actively working to restore affected services, and we will ensure to provide regular updates on resolution activities.

Please don't hesitate to contact customer support if you have any questions.

  • Affected Services: OPEN Gateway - Production Environment

For current system status and planned maintenances please check our status page at https://status.allsecpay.com