Tue 17.01.2023.

Mastercard 3DS Partial Outage

We identified an issue outside of our platform resulting in elevated error rates for Mastercard 3D Secure authentications beginning at 14:11 CET

Customers may be currently receiving errors for MasterCard 3D Secure transactions as some intermittent latency has been detected processing Consumer Authentication with the MasterCard Directory Server.

Kindly note that the issue at hand is outside our sphere of responsibility and influence. It is a a confirmed 3rd party issue.

Our incident response teams are actively working to monitor affected services, and we will ensure to provide regular updates on resolution activities.

Update 16:30 CET: Our team continues to observe a stable error rate. We consider this third party incident resolved.

Update 16:04 CET: We have observed a significant decline in time-outs and customers should no longer be experiencing issues with the MasterCard Directory server.

Update 15:35 CET: MasterCard have been engaged to resolve the issue as soon as possible and further updates will be provided as soon as they are available.