Tue 21.06.2022.

EXCHANGE Gateway EXCHANGE PLATFORM - Degraded 3D-Secure Processing

We are currently investigating elevated errors with 3DS transaction processing.

Update 12:55 CET: We can confirm at this point, that the incident has been resolved

Update 12:41 CET: Temporary fix has been deployed. Errors subsided at 12:39 CET.

Update 12:35 CET: We have contacted our 3D-Secure Vendor and a fix for the issue is being prepared.