Fri 15.10.2021.

EXCHANGE Gateway Elevated rate of unauthenticated Mastercard 3DS transactions

Payments Gateway is currently experiencing an incident impacting Mastercard 3Dsecure transaction-processing services. Customers may be experiencing intermittent latency and possible timeouts when attempting to complete the transaction.

Kindly note that the issue at hand is outside our sphere of responsibility and influence. It is a a confirmed 3rd party issue.

Our incident response teams are actively working to monitor affected services, and we will ensure to provide regular updates on resolution activities.

Update 13:40 CET: Please be advised that this incident has now been resolved.

Update 13:15 CET: A notification from MasterCard was received advising the reference for this incident at MasterCard. No estimated resolution time has been currently provided and the teams at MasterCard are urgently working to resolve the issue.

Update 12:15 CET: We can observe Mastercard 3DS transactions being processed since 11:30. However, as no official info was received from Mastercard, we shall keep this issue as unresolved at this stage.

Update 11:13 CET: MasterCard are actively working to resolve the issue and we will provide a further update once available.

Update 10:45 CET: Our incident response team together with Mastercard Team are continuing to investigate this incident as a matter of the highest priority.