Wed 28.07.2021.

EXCHANGE Gateway 3DS Directory Server Issues

We have identified an issue outside of our platform resulting in an elevated error rate for transactions processed through Visa and Mastercard Directory Server.

Kindly note that the issue at hand is outside of our sphere of responsibility and influence. We are undertaking best efforts to assess the situation correctly for your information.

Update 22:45 CET: Services are stable. We have not observed any errors since 22:05 CET. The issue predominantly affected VISA 3DS traffic and VISA engineers have confirmed resolution of the issue. We will continue to monitor the transaction status closely.

Update 22:15 CET: We are no longer seeing an elevated error rate at the Visa and Mastercard 3DS at this time. We will continue to monitor transactions closely.

Update 21:35 CET: Mastercard directory server seems to be recovering, but we still see elevated errors for Visa.