Sat 29.05.2021.

Visa 3DS Directory Server Timeouts

We experienced an elevated rate of authentication requests failing with ECI 07 on our in-house 3DS servers due to Visa Directory Server timeouts between 16:40 - 16:48 CET and 17:03 - 17:05 CET. The same issue has been observed for transactions processed via 3rd-party 3DS servers.

We will continue to monitor the transaction health closely and with this update we believe this incident has been resolved.

Resolved 21:39 CET: This incident has been resolved.

Update 21:38 CET: Our team has not observed any further timeouts while processing 3DS authentication requests with Visa Directory Servers since 21:24 CET. We continue to monitor transaction health closely but consider this issue resolved.

Update 20:24 CET: We have observed further timeouts between 18:55 - 18:57 CET and 19:20 - 19:24 CET. The situation has improved since then and we did not notice further timeouts. Visa is still working to resolve the issue, our team will provide further updates.

Update 19:00 CET: Our team continues to observe timeouts while processing Visa 3DS1 authentication requests resulting in ECI 07 on our in-house 3DS servers. Our team stays engaged in monitoring the situation. Impacted time frames: 17:50 - 18:00 CET, 18:07 - 18:09 CET, 18:15 - 18:20 CET, and 18:33 - 18:40 CET. This appears to be similar problem as on 27 May 2021, we are observing status pages of other major 3DS/ACS providers, which are all experiencing the same issues. Please do not hesitate to contact your local VISA support if you have any questions or concerns.

Update 17:42 CET: This incident has been resolved.