Sun 09.05.2021.

EXCHANGE Gateway Ongoing issue with NLB VISA 3DS transactions

We noticed elevated timeouts for 3DS versioning requests (VerRes/VerReq), which we believe to be happening between the Visa Directory server and the Nlb Montenegrobank.

Kindly note that the issue at hand is outside our sphere of responsibility and influence. We are undertaking best efforts to assess the situation correctly for your information.

Update 18:00 CET: According to our monitoring, he issue with VISA Nlb cards is fixed by the issuer and now considered as resolved.

Update 13:00 CET: The issue still exists and most of VISA Nlb cards are being declined due to a 3DS error on the card issuer side. This incident is strictyl restricted to Nlb VISA. All other cards and issuers are opetational