Sat 08.05.2021.

EXCHANGE Gateway Elevated 3DS errors

We are currently seeing elevated errors with 3DS transaction for some customers starting 21:12 CET.

Update 01:30 CET: Incident resolved. Situation stabilised. Our incident response teams will continue to investigate and closely monitor affected systems. We will provide further details in our root cause analysis report in the coming days.


Update 01:10 CET: 3DS Component Maintenance has been finished.


Update 01:00 CET: The 3DS Issues were narrowed down to a low performing database query within the 3rd party software used for 3DS Authentication. We are conducting an Emergency Maintenance on this component in the next few minutes.


Update 00:47 CET: 3DS failures are rising again, we are still investigating.


Update 22:27 CET: Mitigation work is currently underway by our team and we are noticing 3ds failures returned to normal levels. We will update this status page until the issue has been resolved.


Update 21:45 CET: We are investigating issues with a subset of 3DS transactions failing. Our Engineers are currently working to resolve the issue as quickly as possible