All systems operational

EXCHANGE PLATFORM Scheduled Maintenance Activity: 3DS maintenance

Completed
Scheduled for 26/03/2024 at 08:00:00 – 10:00:00

Affects

EXCHANGE PLATFORM
Updates
  • Completed
    26/03/2024 at 10:00:00
    Completed
    26/03/2024 at 10:00:00
    Maintenance has completed successfully
  • In progress
    26/03/2024 at 08:00:01
    In progress
    26/03/2024 at 08:00:01
    Maintenance is now in progress
  • Planned
    26/03/2024 at 08:00:00
    Planned
    26/03/2024 at 08:00:00

    In order to maintain service quality and availability for our services, it is necessary to perform required maintenances within our network. We try to keep service impact as low as possible and apologise for the resulting inconvenience. Please don't hesitate to contact customer support if you have any questions.

    • Time Start: 26 March 2024 09:00 AM (CET)

    • Time End: 26 March 2024 11:00 AM (CET)

    • Description: Optimize 3DS high availability

    • Planned Outage Duration: None

    • Affected Services: 3D-Secure Engine

    For current system status and planned maintenances please check our status page at https://status.allsecure.xyz