AllSecure System - EXCHANGE PLATFORM - Elevated error rate for Creditcard transactions – Incident details

All systems operational

EXCHANGE PLATFORM - Elevated error rate for Creditcard transactions

Resolved
Operational
Started 13 days agoLasted 28 minutes

Affected

EXCHANGE PLATFORM

Operational from 2:50 PM to 3:18 PM

Updates
  • Resolved
    Resolved

    We have resolved an intermittent issue that affected credit card transaction processing for a limited number of customers. Our team has implemented a solution and will continue to monitor performance to ensure ongoing stability. We sincerely apologize for any inconvenience this may have caused and greatly appreciate your patience and understanding.

  • Monitoring
    Monitoring

    The error rate has returned to normal rate. Our team continues to monitor the health of the service.

  • Investigating
    Investigating

    We have noticed an increased number of failed transactions and are currently investigating the causes. We will let you know when we have more information.