AllSecure System - Partial 3D-Secure Visa Outage – Incident details

All systems operational

Partial 3D-Secure Visa Outage

Resolved
Operational
Started about 1 month agoLasted about 2 hours

Affected

EXCHANGE PLATFORM

Operational from 4:26 PM to 5:06 PM, Degraded performance from 5:06 PM to 5:21 PM

Updates
  • Resolved
    Resolved

    The issue has been fully resolved according to Visa. Our team will continue to monitor the service.

  • Monitoring
    Update

    Visa's 3DS Service seems to have recovered.

    Our team will continue to monitor closely and update as soon as the external issue is resolved.

  • Monitoring
    Monitoring

    We are still observing elevated errors with Visa 3DS processing.

    Our team is actively monitoring this issue.

    We will follow up with more updates as soon as we have more information.

  • Identified
    Identified

    Our team has determined that this issue is linked to an external issue at VISA.

    We will continue to monitor and update as soon as we have more information

  • Investigating
    Investigating

    We are currently investigating elevated errors with external 3DS transaction processing.